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Introduction  
 
Congratulations on using one of the most flexible and powerful databases in the world, 
OpenInsight from Revelation Software. 
 
This Quick Start guide is designed to let you jump right into application development. We 
recommend that you follow the Getting Started PDF that came with this package, but this quick 
start covers many of the same topics, just not in any great detail. 
 
By following this document, you should be able to: 
 

1. Attach your U2 data to OpenInsight 
2. Convert data dictionaries from a U2 file 
3. Create a data entry form for that data file 
4. Create a Multiple Document Interface (MDI) frame with menu 
5. Hook your data entry form up to the MDI frame 
6. Create a popup for searching 
7. Hook that popup up to your data entry form 
8. Create a report against your data file 
9. Hook up your report to the MDI Frame 

 
 
So, in less than ten steps, you will have created an entire application. 
 
The Getting Started PDF will give more details and background about concepts and terms that 
you should become familiar with as you develop more with OpenInsight. You can also check out 
our website, www.Revelation.com, where we have a free, online threaded discussion where you 
can ask questions, or search on existing issues. 
 
Thanks again for trying out such a great product, and good luck! 
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Starting OpenInsight 
 
I. Starting OpenInsight 
 

1. Launch OpenInsight. 
2. Start, Programs, OpenInsight Development Suite, OpenInsight Sysprog.   
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3. The Application Manager window for the SYSPROG application will be displayed as 

shown below. 
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II. Opening an Existing Application 
 

4. Choose Open Application from the File menu.  The Open Application dialog box will be 
displayed. 

 

 
 

5. Choose the SYSPROG application from the Name list box. 
6. Click in the User Name edit line and type SYSPROG. 
7. Click the OK button the open the SYSPROG application. 

 
Note:   To open any application provided with OpenInsight, enter the Application Name 

in the User Name edit line.  Passwords are not required for sample applications. 
 
The Application Manager window for the SYSPROG application will be displayed, as 
shown below. 
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III. Creating a New Application 
 

8. Choose Application,New Application from the File menu to create a new application.  
The New Application dialog box is displayed. 

 

 
 

The Application Name and Author User Name are the only required items in this dialog 
box. 

 
9. Click in the Name edit line and type TEST_APP. (Spaces are not allowed in an 

Application Name or User Name.) 
 

10. Click in the User Name edit line and type TEST_APP. 
 

Note:   The Inheritance drop down indicates <Default Inheritance>.  This means that this 
newly created application inherits the components of the base application, 
SYSPROG, mentioned above. 
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11. Click the OK button to create the new TEST_APP application. 

The Application Manager window for the TEST_APP application will be displayed, as 
shown below. 
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Connecting To Your U2 Database  
 
I. Requirements 
 

Before you can connect OpenInsight to your U2 database you will need to install the UNIDK 
intercall libraries from IBM on your workstation.  You can obtain a download of the UNIDK 
libraries from the Revelation web site.  

 
II. Making the connection 
 

1. Choose Database Manager from the Application Tools menu. 
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2. Choose Utilities, Other MV Tables, U2 Connection Setup.  The U2 Connection 

Information dialog box will be displayed.   
 

 
 
3. Enter a Volume Name (this is a name to associate your U2 data files with.) 
4. Enter your Media Location (this is the location on your workstation where the 

OpenInsight media tables will be located.)  If the path is not specified then the folder will 
be located in your OpenInsight directory. 

5. Enter your Server Name or IP Address, Login Id, Password and Directory of your U2 
files on the server. 

6. Click Attach volume. 
7. You have now established a connection to the U2 database. 
8. Close and reopen the Database Manager. 
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9. When you reopen the Database Manager your attached U2 tables will be displayed under 
the Volume Name that you specified in the U2 Connection Information dialog box. 
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III. Displaying and editing your data dictionaries 

 
10. Select Table Builder from Open Table from the File menu or press the Table Builder 

button . 
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11. Select File, Open from the Table Builder dialog box. 
 

 
 

Your U2 tables will display.  Select a table to view the converted dictionaries.  
OpenInsight for U2 will convert your U2 dictionaries to the OpenInsight format and store 
them in the Media location you specified in the U2 Connection dialog box. 
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12. Once a table is selected, the converted dictionaries will be displayed in the Table 

Builder.  Double click on any column to view the dictionary details. 
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15. The remaining examples outlined in the Quick start Guide use a table containing the 

dictionary structure outlined below: 
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IV. Adding Calculated Columns to a Data Table 
 

16. Double-click in the first row of the Calculated Columns edit table at the bottom of the 
Table Builder window.  This will display the Calculated Column Attributes window. 

17. Type NEXT_CONTACT in Name field. 
18. Select DATE from the DataType drop down list. 
19. Select D from the Output drop down list. Type D4/ to make it more readable for the user. 
20. In the Edit Formula text box type: @ANS = {CONTACT_DATE} + 7.  Clicking on the 

Test button will check for syntax errors within the formula. 
Note:  @ANS is a system variable used to store the value of a calculated column. Dates 

are stored internally as integers.  In the above formula we add 7 days to the 
Contact_Date.  By applying the D output type the result will display as a date and 
not an integer. 
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21. Click the OK button. 

 
Your Table Builder should now look like the figure below. 
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Working with Forms 
 
I. Creating a Data Entry Form 
 

1. Open the Form Designer.  Click on Form Designer from the Application Tools menu or 

press the Form Designer button . 
2. Choose New Form from the File menu in the Form Designer to display the New Form 

dialog box. 
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3. Select OpenInsight Tables from the Data Source drop-down list.  A list of native tables is 
displayed in the left list box. 

4. Select the OpenInsight table from the list in the left list box (by double-clicking the 
name).  Choose CONTACTS. 

5. The columns from the selected table are displayed in the Columns list box.  
6. Select columns from the Columns list box to use in creating the OpenInsight form. To 

select a column, double-click on the column name in the Columns list box or select the 
column and click the ADD button.  The selected columns are displayed in the selected 
columns edit table. The order in which columns are selected sets the tab order for the 
controls in the OpenInsight form being created.  Select all the fields. 

7. The default control type for columns is an edit line. The edit table control is the default 
control type for a multi-value column.  If you want to specify another control type, select 
the appropriate column row in the selected columns edit table and double-click to display 
a list of control types.  Double-click the required control type in the control type list for 
the specified column.  The new control type is indicated in the selected columns edit 
table. 

8. If you want to remove a column from the selected columns edit table, select the column 
row and click the Remove button.  The row is deleted from the edit table and therefore 
not displayed on the OpenInsight form. 

9. When all columns have been selected and the required controls specified, click the OK 
button to create the default OpenInsight form.   The form should resemble the following: 
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10. Save the form by choosing Save from the Form Designer File menu.  The Save As dialog 
box will be displayed. 

 

 
 

11. Type CONTACTS in the Form Name field and click the OK button. 
 

II. Adding Data to the Table  
 
12. Choose Preferences from the Form Designer Tools menu and verify that Actual data 

tables is selected in the Testrun with: group then click the OK button.  This assures that 
the data you create is saved in the CONTACTS table. 
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13. Click the Test Run button  or choose Test Run from the Form Designer File menu. 
 

14. The first time that the CONTACTS form is executed you are prompted for an initial 
value for the sequential key counter.  This is because you defined the ID column in the 
table as having a default of SEQKEY.  %SK% is a system variable that keeps track of the 
sequential counter. 

 

 
 

15. Type an initial value then click the OK button.  The form will display with the ID field 
containing the value entered in the sequential key dialog box.   

 
16. Enter the following data for this record: 
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Note:  Notice that when you tab from the ID field, a date is displayed in the Next Contact 
field.  This is a calculated data field which automatically recalculates.  When data is 
entered into the Contact Date field, the Next Contact will be updated with the correct 
date. 

 
17. Press the F9 key or choose Save Row from the File menu to save this record.  The record 

is saved, the form is cleared and the ID is updated to the next sequential key. 
 

18. Continue entering the next three records: 
 

 
 
 
 
 
 
 
 
 
 

19. After adding the last record, choose Close from the File menu to exit the form.  This will 
return you to the Form Designer. 
 

III. Creating an MDI Frame  
 

Multiple Document Interface (MDI) windows are child windows or OpenInsight forms that 
belong to a parent frame and are displayed in the window client area.  The MDI Frame is the 
main window and normally contains a menu, a client area and a status line.  The MDI Frame 
controls all of the child windows.  The MDI children are the OpenInsight forms that appear 
within the client area of the MDI frame. 

 
 

1. Select New MDI frame from the Form designer File menu to display the Select Style 
Sheet dialog box which lists the existing OpenInsight forms in the current application. 

 

Name Jill Smith Robert Jones Lawrence Granville 
Address 22 Waldorf Dr. 16 Scott Terrace 18 Riverview Ave. 
City Youngstown Asbury Hibbing 
State OH MI MN 
Zip 06322 07299 05744 
Tel No 888 121-9955 877 333-4444 800 532-9876 
Email jsmith@smith.com Rjones99@verizone.com Lg052@roam.net 
Contact Date 03/21/10 02/28/10 03/31/10 
Hot Lead True False True 
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2. Click the OK button to exit the Select Style Sheet dialog box without selecting a style 
sheet.  

 
An MDI frame with an MDI client window is displayed.  The MDI client window is part 
of the frame window and cannot be deleted or copied.  MDI child windows are confined 
to the MDI client area.  The text “MDI Client Window” is visible only during 
OpenInsight form design so that you can distinguish the MDI client area from other 
controls.  The Client Window should display as follows: 

 

 
 

The MDI Client Window can be resized. 
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IV. Creating an MDI Child 

MDI Child windows are those that reside within the MDI client area.  MDI Child windows 
can be any OpenInsight form created for the current application.  MDI Child windows are 
often created prior to creating the MDI frame.  A feature of MDI child windows is that they 
do not contain menus.  Menu functionality is provided by the frame. 

 
An MDI child is executed from the MDI frame with the BASIC+ function 
START_MDICHILD. 

 
1. Choose Design from the Menu menu.  The Menu Builder dialog box is displayed. 

 

 
 

The first menu item is highlighted. 
 

2. Select Insert item after selection from the Edit menu. 
3. Type ‘&Contacts’ in the Popup/item text field.  The Popup/Item ID: field is automatically 

populated. 
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4. Choose Exit/Update from the File menu. 

 
 

5. Choose QuickEvents from the Menu menu.  The QuickEvents dialog box is displayed. 
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6. Choose FILE.CONTACTS from the Event drop down list. 
 

7. Choose Start MDI child window from the QuickEvent Options: list.  The QuickEvent 
dialog box will be populated with default settings for the Start_MDIChild function. 
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8. On the Parameters: change ChildName to ‘CONTACTS’ and CreateParam to null (‘’).  
Include the single quotes. 

 
9. Press the Apply button.  This will place a <q> next to FILE.CONTACTS in the Event 

field. 
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10. Press the Close button.  This will return you to the MDI Frame.  
 

11. Select Save from the File menu.  Enter TEST_APP_MDI for the name of the form. 
 

 
 

12. Test run the form.  Choose Test Run from the File menu in the Form Designer.  The 
following will display: 
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13. Choose Contacts from the File menu.  The following screen will display: 
 

 
 

Your application now contains MDI capability. 
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Working with Popups 
 
I. Creating a Popup 
 

1. Launch the User Interface Workspace by clicking on UI Workspace from the Application 

Tools menu or press the UI Workspace button . 
 

 
 

2. Choose New from the File menu; choose Popup from the New Entity dialog box to 
display the Popup Designer below. 
 

3. Type: Contacts in the title edit line on the General tab.  This is displayed in the title bar of 
the popup.  Review the other options on this tab and accept the defaults, then click the 
Source tab. 
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4. Click the Source tab where you specify a data source used to populate the Popup.  
Review all options and choose Select Rows from Table. 
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5. Click the Selection tab (which is dependent on the Source you selected). Regardless of 
the appearance of the Selection page, the process to be performed is that of selecting the 
specific data to be displayed in the Popup. The definition of a selection formula may be 
required. 
 
Select CONTACTS from the Table drop down.  Choose the fields you want displayed 
from the Available list and click the right arrow button.  This will place the fields 
selected in the selected list. 
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6. Click the Layout tab to describe how you want the Popup to look including column 
headings and alignment, width, etc.  This is pre-populated with settings from the data 
dictionary. 
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7. Click the Value tab where you specify what information you want the Popup to return, 
and specify the number of selections that can be made in the Popup. 
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8. Click the Options tab where a number of miscellaneous characteristics of the Popup are 
specified. 
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9. Save the Popup, and then test it by choosing File, Test Run. 
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II. Adding Popup Functionality to a Window 
 

The most common use of a Popup is to provide users with a list of choices during data entry.  
The following procedure will demonstrate how to add a button to an existing form and the 
Event Handler necessary to execute the Popup and place the results within a data field. 

 
1. Open the Form Designer. 
2. Select Open from the File menu.  Choose the CONTACTS form. 
3. From the Controls tool bar select a button by clicking on the OK button icon, in the upper 

right corner 

 
 

4. Place the control on the form by moving the mouse cursor to a location on the form 
where you want to place the control.  The mouse cursor changes to the control’s icon 
with a + appearing to the left and above the icon as soon as the mouse cursor enters the 
form.  The + is used to help position the control.  Click the left mouse button where you 
want to place the control.  The control is displayed in the form in the selected state (with 
handles visible).   
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5. Double-click on the button.  The Push Button Properties window will appear.  Change the 
Name of the control to “BTN_CHOOSE_CONTACT” and the Text that is displayed on 
the control to “Choose Contact”.  
 

 
 

6. Click on the Events button to display the QuickEvent dialog box. 
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7. The CLICK event will be chosen by default. 
  
8. Click on the Scripts button.  This will launch the Event Editor.  In the Editor type the 

following code: 
 
declare subroutine Set_Property, Send_Event 
declare function Popup 
 
retval = Popup(@window,"","CONTACTS") 
Set_Property(@window:".ID",”DEFPROP”,retval) 
Send_Event(@window:".ID","LOSTFOCUS") 

 
9. Select Check Syntax from the File menu.  Any errors will be displayed at the bottom of 

the Event Editor window.  If the syntax is correct the status line will display “The syntax 
is correct”. 
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This will cause a popup to display when the Choose Contacts button is clicked.  The user 
may choose a Contact.  The value chosen will be placed into the ID control on the 
Contacts form.  When the ID field loses focus a read of the ID placed into the field will 
occur. 

 
10. Select Exit/Update from the File menu.  This will save the code and return to QuickEvent 

dialog box. 
 

11. Press the Apply button.  This will place a <s> next to CLICK in the Event field. 
 
12. Press Close.  This will return you to the Push Button Properties window.  Select OK on 

the properties window.  This will return you to form. 
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13. Choose Save from the File menu. 
 

14. To test run the MDI Frame, access the Contacts form from the File menu and click on the 
Choose Contact button.  
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Working with Reports 
 
I. Report Builder+ 
 

The OpenInsight Report Builder is a tool used to create R/List type reports.  Using the Report 
Builder+ the developer or end-user can create columnar reports on any attached table with a 
minimum of effort. 
 

II Creating a Report 
In this procedure you’ll create a columnar report based on the CONTACTS table. 
Exit all tools and return to the Application Manager. 
 
1. Click on Report Builder from the Application Tools menu or press the Report Builder 

button . 
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2. Choose New Report from the File menu. The Select Table dialog box is displayed.  Select 

the CONTACTS tables 
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3. Click the OK button. The Font dialog box is displayed followed by the Select Columns 

dialog box. 
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4. From the Available Columns list box, select the following fields by double clicking on 

the Column Name for each specified field and clicking the > button. 
 
ID 
NAME 
TEL_NO 
CITY 
STATE 
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5. The selected field names display in the Selected Columns list. 
 

 
 

Note: If the Selected Columns are not in the order in which you want them to appear on 
the report, click the Reorder button to display the Reorder Dialog box. 
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6. The screen will now resemble the following: 
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7. To save the report, choose Save from the File menu.  Type CONTACTS as the report 

name and click the OK button. 
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8. Choose Print Preview from the File menu.  The following report will be displayed. 
 

 
 

9. Click the Close button on the Preview window. 
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Setting an Application Entry Point 

 
The application entry point is the first window that is displayed when the application is 
executed at runtime.  For our purposes this will be the MDIFrame TEST_APP_MDI.  The 
following steps will define the application entry point. 
 
1. Choose Application Properties from the Application Manager File menu to display the 

Application Properties dialog box shown below. 
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2. Click the SETUP ENTRY POINT button (in the bottom left hand corner of the dialog 

box). The Setup Application Main Entry Point dialog box is displayed, as shown below. 
 

 
 

3. Clear the No Application Entry Point check box. The window names in the Window 
Name list box become enabled. 

 
4. Select the form TEST_APP_MDI in the Window Name list box. 

 
5. Click the OK button to update the application Entry Point option and return to the 

Application Properties dialog box. Click the OK button to close this dialog. 
 

6. You will need to close and reopen OpenInsight to the TEST_APP application.  Now 
choose Run Application from the File, Application menu.  Your application will now 
launch. 
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7. Select the TEST_APP application and enter TEST_APP in the User Name edit line, then 
click the OK button to execute the TEST APPLICATION. 

 
8. The TEST_APP_MDI window is displayed in runtime mode. 

 
Congratulations! You’ve successfully completed your first application using OpenInsight. 
And what you’ve learned here is just the beginning. You may continue by taking a look at the 
sample applications that are included with OpenInsight, or begin your own development 
project. Whatever your choice, we wish you continued success using OpenInsight. 
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